Suddenly can't open expo project

edit: It seems simply that the ‘open ios simulator’ is passing the wrong url to open to the simulator. I don’t know how to fix this, however

Suddenly I am not able to open my expo project on iOS simulator or my real iphone device. No matter what mode I start my expo project in (localhost/lan/tunnel), when I click ‘run on ios simulator’ it tries to open to exp:// This happens even when the project tunnel is running on a standard tunnel url, etc.

When trying to launch on iphone by scanning the QR code, the url is correct, but I get the same error as is seen on the simulator. The error seen is

I still get a response when I navigate to the relevant url in the browser, giving me the json associated with the project.

Has anyone else experienced this? Or have any ideas what might be causing it?

Hi jmask, you can change the ‘host’ to ‘lan’.

hi @feamobile. I’ve tried this. The project refuses to open no matter what I have the host set to. Even when I scan the appropriate QR code on my iPhone

Hey @jmask,

Can you try updating the Expo Client on the simulator? You can reset the content and settings on the simulator and then just try run on ios simulator and it will install again. In case you run into any issues, there’s some troubleshooting here:



This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.