Expo app does not open in ios simulator

I am new to react native and expo and excited to be working on this new project.

I used the CRNA script and got my project up and running on my macbook air. I’ve been able to load my project on the iphone simulator and develop.

I have an iMac I prefer to use when I am home. I pulled the github repo.

Got the project setup and dependencies installed.

When I go to load the app in expo through the iphone simulator, it opens expo and just stays on a screen that says expo on the bottom.

I can’t toggle into the developer menu, my project doesn’t load. I’ve deleted and reinstalled expo, deleted and reinstalled my node modules.

I’m lost at what to do at the moment because I receive no error messages. I’m running on iPhone X 11.4 and the version that works on my macbook air is iPhone X 11.2. Otherwise the projects should be identical.

It’s been frustrating. I can continue working on my macbook air, but my imac is more powerful and I’d prefer to use it.

Thanks for any/all help and direction. Below is a screen shot of the screen I am stuck on.

Hey @hancho,

I pinged about this internally as you already tried the steps I would normally recommend to try and fix this. I’ll circle back when I find out more.



Thanks @adamjnav ,

Still no luck, so keep me posted.



Hey @hancho,

Can you try reseting contents and settings in the simulator?



1 Like

Hey @adamjnav,

Sorry for the delay, but I finally got back to trying to fix this issue…

I deleted the simulator, and reinstalled it. I also deleted my app directory and repulled everything from git, reinstalled all the dependencies and packages and still no luck.

I can’t toggle the developer settings in expo when it’s open.

I am going to create a new react native app with the create react native script and see if that opens.

Yea so same issue with creating a new app, sittings on the expo screen without loading the app or ability to toggle the developer tools.

this happens with many softwares , and it always happens in ios simulator
i have seen this issue alot jeez :sleepy:
https://bluestacks.vip/ https://textnow.vip/

Hi guys, sorry about the trouble. We’re not sure how to reproduce this behavior on our side. @hancho - you said this works on your macbook but not on your imac. Can you try to find any system information that is different between the two machines? (Xcode version, macOS version, network connectivity, I’m not sure)

Hey @ben,

Computer that won’t load the expo app -
Xcode 9.4.1
macOS High Sierra 10.13.6

Computer that does load the app -
Xcode 9.2
macOS High Sierra 10.13.5

I am going to try and downgrade xcode on my imac and see if there is a difference.

@ben so installing Xcode 9.2 solved the issue.

Hopefully anyone else experiencing anything similar can benefit.

I found the download for Xcode 9.2 in apples developer tools.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.