ios simulator opens fine, but doesn't show react native app

The expo app opens fine on my physical device (iPhone X). Works fine when updating code.

However, when I “Run on iOS simulator” it opens the simulator app and displays the iPhone home screen with all the native iOS apps. Why doesn’t my react native project open right away like on my physical device? Where do I go??

Hey @robbiebullock,

What version of the expo-cli and Xcode are you running? Also, can you try running the command expo start --ios and see if that makes any difference?



Thanks, @adamjnav

I’m running:
xcode 10.1

Unfortunately sudo expo start --ios has the same result.

Interesting, can you try running reset content and settings on the simulator and see if that does anything?

Sorry, no luck. Not sure if I need to do this, but I’m getting errors when I attempt…

Hey @robbiebullock,

What errors are you getting when you try those steps?

I’m unsure of where to extract the contents. And where to make the new directory.

The instructions are not very clear to me. The part is also confusing. Could you please send a more concise step-by-step guide? It would be greatly appreciated. Thanks a lot!

| => xcrun simctl install booted [/Users/froedtertdeveloper02/]

An error was encountered processing the command (domain=NSPOSIXErrorDomain, code=2):

Failed to install the requested application

An application bundle was not found at the provided path.

Provide a valid path to the desired application bundle.

I’m having the exact same problem, also having tried to bring a fully functional android tested app into iOS - given up and started a blank project. I’ve even deleted the app project and created a new blank one but can’t get it to run.

I can’t quite understand how this is not a react-native issue? why is it closed? is there a solution?

As per the recommendations, I can’t unlink components because the project that referenced anything has been deleted.

I don’t think downgrading react-native is a very good solution - especially if it is not a react-native issue! but i’ve tried all the other suggestions including:

react-native start --reset-cache
watchman watch-del-all
npm cache verify

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.