expo app not opening after downloaded on IOS simulator

Hi folks.

Please I need support. I have been working on the expo for a few days now and I have been using an android emulator and my IOS (real device) for testing, everything has been working great. just recently that I decided to use the IOS simulator from Xcode to load my app.

then the issue rises. the issue is that the app gets opened and the expo app gets installed on the simulator it does ask me if I want to open the app and I opened it. but

“the expo app always closes back after a few minutes.”

I have tried different simulators iPhone 8 - X but still the same

React Native : 0.64.3
Expo SDK : 43.0.0
Xcode : 9.4.1 and 9.2
Computer : MacOS High Sierra 10.13.6

Thank you for your help.

Hey @sheriffgrandeur, your Xcode is rather out of date. Can you update it and try running your simulator flow again?


hi @adamjnav. thank you so much for your reply.
and yeah, it looks like I can’t use any other Xcode version other than those(9.4.1- 9.2) on my mac.

I have tried to install some newer versions but they not working.

Unfortunately that will be a blocker for you to build locally. I’d suggest building via EAS. For future reference, it’s best to keep your local Xcode version within the version range listed here. Currently that would be 12.5-13.0.

thank you one more.

I don’t know what “EAS” means, could you drop me a link to check it out?

Sure thing! You can read all about it here Expo Application Services - Expo Documentation

okay, thank you i would check it out. i will keep using the emulator for now