iOS simulator opens fine but the react native expo app doesn't show up

Expo CLI version 4.0.17
iOS 14.3
iPhone 12 simulator
MacBook Pro - M1 chip
Mac OS Big Sur 11.1

Command used:

sudo expo start --ios


“expo”: {
“name”: “MYAPPNAME”,
“slug”: “MYAPPNAME”,
“version”: “1.0.0”,
“orientation”: “portrait”,
“icon”: “./assets/appIcon.png”,
“facebookAppId”: “1181162272259970”,
“facebookDisplayName”: “Test”,
“facebookScheme”: “fb1181162272259970”,
“splash”: {
“image”: “./assets/splash.png”,
“resizeMode”: “contain”,
“backgroundColor”: “#ffffff
“updates”: {
“fallbackToCacheTimeout”: 0
“assetBundlePatterns”: [
“ios”: {
“supportsTablet”: true
“web”: {
“favicon”: “./assets/favicon.png”
“sdkVersion”: “38.0.0”,
“platforms”: [
“description”: “”

Terminal stuck at
Opening exp:// on iPhone 12

No errors or any other logs after this

Hey @ovidtech, out of curiosity does the Simulator have the Expo client app installed already? If it doesn’t, can you try running expo client:install:ios to install it and then run expo start --ios and see if that resolves the issue?


1 Like

When i run this expo client:install:ios it says done . But when the expo start --ios is run it just says opening and doesn’t open the app

Okay … i got a work around.

The solution was to

sudo chmod -R 777 ~/.expo/

sudo rm -rf ~/.expo

npm start

( without sudo )

i think the rot cause was i installed expo-cli with root / sudo . And hence all the folder permissions issues. after npm start , i could see the expo app installed on the ios simulator and happy days are back. Now the app is working fine on the ios Simulator.

1 Like

I have similar problem, but I found that Expo Go is Intel App.
After installing Rosetta (Xcode prompted me for installation) everything works fine!

1 Like

Appreciate the knowledge George! Your solution worked for me!:slight_smile: