Expo Managed app can't get submitted to Apple AppStore due to App Thinning

Sometime today, something changed where our builds are no longer getting through Apple TestFlight. The error message says that the app cannot be processed to failure in app thinning. I’ve tried to revert back to the version that was last built, and it’s now still getting the same error. Is anyone else seeing the same issue?

Same here.
We’ve faced that thining issue when updating our app. I’ve tried going back to a commit where we’ve already passed the appstore connect and that same build also fails to make it through. Is there something wrong with the build server or something?
I’m not sure though. I’ve removed some packages today and I assumed that might have been a issue. @bluedevil2k6 Did you make any changes to the app that might ruin your expo packages or so?

1 Like

@msj-js No. Between the build that worked (yesterday morning ~9am) and the first build that failed, (yesterday evening ~7pm), package.json did not change. The code changes were all frontend JSX components that were UI related, not sure why that would impact Bitcode.

Also, something super weird started to happen. expo-updates started to work by itself. expo-update is an installed package, but it’s not imported and there’s no code to fetch new updates, but somehow the binary out there is fetching new updates automatically. This has never happened before.

@msj-js Can you upvote this issue so hopefully we might get some attention on this? I’ve got some time critical items that need to be addressed in the next 48 hours and this is killing me.

1 Like

Same here. It started a few days ago.

The processing is stopped by apple store connect and we receive the following alert:

While processing your iOS app, **, errors occurred in the app thinning process, and your app couldn’t be thinned. If your app contains bitcode, bitcode processing may have failed. Because of these errors, this build of your app will not be able to be submitted for review or placed on the App Store. For information that may help resolve this issue, see [Tech Note 2432]


Did you guys found any workarounds for this?

@atlasgov No. Have not found any workaround for this. This started to fail for us between 9am PT and 7pm PT yesterday (March 8). This does coincide with Apple’s announcement, and they do seem to have a tendency to push changes to AppStore / website during these events, but typically it’s during WWDC and not a hardware announcement event like yesterday. Please upvote this so that we can get the Expo team’s attention.

Just wanted to add that we are also experiencing this. Got the email from App Store Connect and cannot move forward with store deployment.

Still facing same issues with SDK 43.

@charliecruzan @notbrent Are you guys seeing this? Any insights into whether this is due to an Apple change or something on the Expo build servers?

Same issue here

Here’s a quick workaround I used. Just migrate to EAS for only iOS build. I didn’t have time to wait for expo to reply to this thing so just tried and it worked.

1 Like

To our knowledge, this is an unexpected change by the App Store and the Classic Build system has not changed. We are investigating this issue. Given this is an external change it will likely take time to identify the root cause to begin a fix.

Developers have reported that using EAS Build has fixed this issue. EAS Build or building locally are the best paths forward if you need to submit builds for review before the Classic Build service is updated or the App Store starts accepting these builds again. The Classic Build service will run until the beginning of next year, so while it is not otherwise urgent to migrate to EAS Build or local builds, it will be necessary.

How do you build locally ? is there a guide ?

1 Like

I tried EAS build, and I have this
Fastlane build failed with unknown error.

I’ve used EAS build and still receive this issue… os there any estimate on when this could be solved?

Thank you!

I am facing the same issue. expo build failing, i have tried since yesterday 10 builds but no help. Is there any way to convert existing app to EAS. i am reading here this is also not useful :frowning:

The “Classic” way is to use turtle-cli. This is like the old expo build:ios or expo build:android:

You can also build locally with EAS Build. Basically you just add --local to the eas build command. See the following for details:

I suppose there’s another possibility too, but personally I would use eas build --local:

  • Make sure everything is committed to Git so you can revert the following change.
  • Run expo prebuild to generate the native code. (This is similar to the old “eject”)
  • Build like a normal RN app using Xcode and Android Studio
1 Like

Here’s the migration guide:

For more information, see: EAS Build - Expo Documentation

Still have the same issue even we trying with eas build, please we need a solution team!

Thanks for your effort expo team

This is the only report we’ve received about an app made with EAS Build receiving the error about App Thinning. The issue might be specific to your app. If you are able to reproduce the issue locally, that will probably help you diagnose the issue the fastest. Apple has some guidance here: Technical Note TN2432: Troubleshooting App Thinning and Bitcode Build Failures

I recommend looking through your native dependencies or Xcode project (if you have prebuilt it) to see if there is are any uncommon modules that could be affecting your app but not others.