Expo App Refusing to Load

My app has suddenly ceased to function with expo on my iPhone. I cannot for the life of me figure out what is wrong.

Symptoms: The app was initially returning a cryptic redscreen with “no message provided”.

Annoyed that I couldn’t fix this, I decided to start a new project in my IDE and add my files manually until I could find which one was the source of this strange behavior. It didn’t work. For a while it gave me standard “could not locate file: x” errors, until all the files were added. Then, expo proceeded to simply load eternally. My terminal output doesn’t even indicate a javascript bundle being created. After a while the expo app gives up and tells me to check my network, saying that I may be using a LAN connection (not true). I’ve tried both wifi networks my University provides, to no avail.

I have commented out my code until App.js is just the bare minimum to display “hello world” and the error persists. I have no idea how to resolve this but it’s completely stopped my development – I’ve probably created 3 or 4 different projects, both in my online IDE and on my machine, and nothing fixes this. Please help! It is extremely frustrating.

Hey @gsk,

I agree this is definitely an annoying problem. I managed to repro the same cryptic error screen with a fresh project. I’ll let you know when I find out what would be causing this. Can I ask, what are you using exp or XDE to start your project?


Hey @adamjnav,

I’ve finally fixed it – but I don’t know how.

I’m using the exp command line toolset to run my project.

I got it to work by having homebrew (I’m on mac) uninstall node and npm, then reinstalled. Next I downgraded npm to 4.6.1 as I know expo sometimes doesn’t get along with 5+. Then I started a new blank project from the command line using ‘exp init’ and slowly added my code back. When I ran into this error I began copying and pasting the relevant file one function at a time.

I think the error was being caused by me accidentally declaring

var old_method = false,

which obviously needed a semicolon. Gotta cut down on that Python, I guess. Anyways, this and a few other things being fixed, I was able to add in all of the rest of my files and I am now happily coding away. Let me know if there are any other ways I can help.

@adamjnav just an update – I get this ‘no message provided screen’ whenever I have an error in my javascript, which is often! I’m not sure what I did to my computer to screw with it this badly but at least I can work around it now.

@gsk Thanks for the update. I mentioned it internally and one of our team members believes it may related to a network issue. I’ll keep in touch as I find out more. Certainly don’t think it is something you’ve done.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.