New updates to expo tools are a buggy mess

  1. I can’t open my project anymore using the Expo XDE tools, it always does something weird or doesn’t load at all.

  1. What’s up with inability of using the QR scanner for IOS.

  2. I can’t open any of my projects uploaded to expo, it shows me “internal server error”.

Hey there @amansahil, sorry you’re running into trouble.

With regards to #2, we know this is a disruptive limitation. Please read this blog post from last week for more details and suggestions for how to work without QR codes.

For #1, it looks like maybe we’re having trouble starting a tunnel for your project. This might be due to issues connecting to our third-party tunnel provider. As a workaround, are you able to switch the connection to localhost or LAN by clicking the gear icon?

For #3, we’re not aware of any server errors viewing our projects right now. Can you provide more details about the url you were trying to load, what device (or PC) you were using, and what region of the world you were trying to connect from?

Hope this is helpful,

Hey I’m trying to load my projects on IOS and I get this for hours

Then I decided to publish the project and page just shows internal server error

install the latest version of exp, xde, or react-native-scripts

For the iOS loading screen which never disappears, can you make sure to update to the newest version of XDE? We fixed a similar issue a few days ago.

Can you paste the log output from when you tried to publish?

Hey, just realized you guy stopped allowing people to access other peoples expo project. Sorry that’s my fault, I didn’t sign in to access my app. However my exp and xde are updated to the latest version and I still get the never ending loading screen.

Hmm, sorry to hear the loading screen is still never going away. The newest version of XDE is 2.24.3 at the time of writing, and the newest exp is 51.4.0 at time of writing.

Here are some steps you can take:

  • Make sure your packager is not showing any errors in XDE. If it is, resolve them and then click Restart.
  • Make sure the path to your project doesn’t contain space characters. (this is the bug we recently fixed, so it should not matter, but just in case.)
  • Try using LAN instead of Tunnel if your network is able to support it.
  • If you are able to access a Mac computer, can you try running your project on iOS simulator? You might get more information about the hanging loading screen.

If none of these things help-- we’re hoping to release an updated version of the iOS app to the App Store in the next couple days which should resolve the issue.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.