Expo client on iOS is unable to load any apps

I’ve tried to load the following by visiting them on iOS in Safari and tapping the “Open project using Expo” button, they all produce the same error “There was a problem loading the requested app”. I’ve tried from 3 iOS devices (2 people in 2 countries).

  • @community/native-component-list
  • @consento/consento
  • @chmac/generous-plans

All of these work in Android (although the native-component-list crashes almost immediately). The last one is a copy of the typescript 2 tab starter that I just deployed.

Is this a temporary issue? Should I report this bug somewhere else?

The above are expo.io links but as a new forum user I can’t post 3 links, so…

1 Like

Hey @chmac,

This might be related to the fact that you can only open projects on iOS that have been authored by the expo account you’re signed in with or that you’ve been given team permissions to view. Is that the case?


@adamjnav Thanks, that explains it. Is this a recent change?

Is it documented somewhere? I was trying to figure out how it worked on iOS and couldn’t find anything that explained how / when projects would run in the iOS client.

Unfortunately it’s been that way for a while now. We had to make the change to comply with Apple’s guidelines and keep the Expo client in the App Store. You can read more here: https://blog.expo.io/upcoming-limitations-to-ios-expo-client-8076d01aee1a

@adamjnav Gotcha. Thanks for the update. Would be awesome if the app said “You don’t have permission to view this app” rather than the “There was an unexpected error” message. Is that something I can file as a suggestion somewhere?