Errors on exp build:ios


I am trying to build a project using exp build:ios but I keep getting the error:

Unable to generate IPA.
unable to build and sign IPA

It also errors on “running gulp task”, not sure if that’s related.

[stderr] (node:12353) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): StatusCodeError: 403 - “<?xml version=\"1.0\" encoding=\"UTF-8\"?>\nAccessDeniedAccess Denied6B2FB487E800B124/hBGXAl+xUetxfbv0KF7MzBLS4hxh8C3dRzt1ecMEvJ+pwsV/zP3TNlg0CmphPJ6F+KcZx1a2d4=”

I was able to build the .apk.
I’ve also been able to build an .ipa for another project.
I tried exp build:ios -c after removing everything from as well.

Is there some way I can debug to figure out why it can’t generate the IPA?

Here is my build log:


1 Like

I have the same problem for a couple days and its killing me, I was able to build before but it suddenly broke, and I did exactly the same stuff you did but it did not fix the build for me either.

I fixed it by revoking all of my certificates and starting over from scratch.

I revoked and built it, but I still get the same error. Did u do anything else?

My exact steps were:

exp build:ios --revoke-apple-dist-certs --revoke-apple-push-certs -c

Select every single certificate that was presented and revoke them all

Then I had to go into and manually delete some push notification ones that had been created, but weren’t deleted from the terminal

Then run exp build:ios -c again and select “Let Expo handle it” for everything.

Now my latest problem is that my other projects won’t build, I guess because they were using certificates that I revoked.

Good luck.

Thanks for your response, but mine did not fix

Try this:

Go to

Go to “Certificates / All” and “Revoke” anything related to your app.
Also “Revoke” anything with the type “iOS Distribution”

Go to “Provisioning Profiles / All” and “Delete” anything related to your app

Do the steps from here:

Run exp build:ios -c
Let expo handle everything EXCEPT for the distribution certificate
Provide the .p12 file and the password you made after following that website instructions

If that works, I THINK use that .p12 for any future stuff.
Because Apple won’t let you have a lot of distribution certificates, so you need to use the same one (if I understand it correctly).

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.