iOS app build fails

Hi everyone - after a good while figuring out how to manually create certificates, I got the build process working but it hangs and errors as seen below (13:57:04)

Any insight on this would be helpful. All my certs look verified.

building and signing IPA
[13:56:43] Using gulpfile /usr/local/turtle-agent/tools-public/gulpfile.js
[13:56:43] Starting 'ios:build-and-sign-ipa'...
provisioning profile copied to home directory
done retrieving provisioning profile data
checking if teamID is present in keychain and that certificate is valid...
ensured certificate is valid
writing export-options.plist file...
created export-options.plist file
generating IPA...
[stderr] [13:57:04] 'ios:build-and-sign-ipa' errored after 21 s
[stderr] [13:57:04] Error: Process exited with non-zero code: 1
unable to build and sign IPA
[stderr]     at ChildProcess.child.on (/usr/local/turtle-agent/tools-public/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
[stderr]     at emitTwo (events.js:125:13)
[stderr]     at ChildProcess.emit (events.js:213:7)
[stderr]     at maybeClose (internal/child_process.js:927:16)
[stderr]     at (internal/child_process.js:348:11)
[stderr]     at emitOne (events.js:115:13)
[stderr]     at Socket.emit (events.js:210:7)
[stderr]     at Pipe._handle.close [as _onclose] (net.js:545:12)

Hi @relishworks - I’m not sure why there aren’t more details along with that generic error message (unable to build and sign IPA). Could you post the build ID so I can look through our server logs to try and pinpoint the error?

In the meantime, it may also be helpful to search the forums for that error message and see what has helped other people in this situation.

I same

I’m attempting to do this with an enterprise account, and know about the additional flag - but I’m still getting a very general error (as you said) with not much to go on.

Hi @relishworks @isthaison - could you try re-running your build, and then post the new build ID here if it fails again? We’ve deployed a change which will allow us to see more detailed logs for failures.

Apologies for the inconvenience.

@esamelson I’m had build with

Nice looks like some more detailed logs. Still lost on me though :slight_smile:

I was attempting this build using the enterprise account we have - when I moved to using a normal developer account, I was able to build with no issues. So my problem is solved, per se, but I feel like there’s still an issue there.

@isthaison are you also using an enterprise account? I’m not seeing any additional information in the logs for your build, unfortunately.

1 Like

I’m also having the same issue:

I tried a few times, each time using the -c command and starting from scratch. I’ve also recreated my distribution cert, push cert and mobile provision from scratch. I’m providing the details to expo as opposed to letting expo get them from the iOS dev center. Last time I did that it created a new distribution certificate every time for some reason. You can only have 2 max.

Some things to note.

I’ve previously successfully build an iOS standalone, but I used different credentials (so we could have a standalone app in testflight that wouldn’t overwrite the current production app). I’ve since switched the bundleID to the live version, and cleared the credentials. I’m also now using the production certs (and no longer the test cert).

Any thoughts?


I had build pass with other account.

We got this error when trying to build:

[stderr] /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/ui/interface.rb:163:in build_failure!': [!] Error packaging up the application (FastlaneCore::Interface::FastlaneBuildFailure) [stderr] [12:02:02] 'ios:build-and-sign-ipa' errored after 4.2 min [stderr] [12:02:02] Error: Process exited with non-zero code: 1 [stderr] from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/ui/ui.rb:17:inmethod_missing’
[stderr] at ChildProcess.child.on (/usr/local/turtle-agent/tools-public/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
[stderr] from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/error_handler.rb:112:in `handle_package_error’
[stderr] at emitTwo (events.js:125:13)

Can someone from Expo team take a look at what went wrong with our build after 2 hours in queue? Build ID: 97fdeb68-1998-43e0-ba2a-9bc0ac9430c0

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.