Standalone apk freezes at launch screen

If I use the expo app to load project, all works fine.
After doing a exp build:android and installing the apk,
the application will not launch, freezes at the loading screen.
Any idea how to solve this?
All packages updated to latest versions.


Hi! Please send us more information to help us figure this out. Logcat logs, the apk you generated, and source code are all useful.

I am also seeing this, we made a production build yesterday after having tested our app using expo as well as an older binary we built, probably 1 week ago, and the new build silently fails to get past the app splash screen. Interestingly if you tap around on the screen, the app is there and functional, just covered by the splash!

This is not happening in our iOS binary, same js code.

to be sure, i opened the same tag as our last good binary build and rebuilt today the new binary gets stuck on the splash screen.

We don’t see anything of note in the logs

1 Like

I noticed that the file name structure changed recently which points at a change in the build system, it seems to coincide with the broken builds, but that might just be noisy data

I am happy to share the 2 apks with you if you tell me where to send them

The same issue with me.

Yesterday I build my standalone Android app without any issues, but today the problem is that it freezes on the splash screen :confused:


Hi, having the same issue. No problems during my last standalone apk (July 12th), but I’ve been trying since yesterday (July 26th) still stuck in splash screen. Hope there’s a workaround soon.



Hi, i having the same issue. My standalone apk stuck on splash screen and keyboard open unexpectedly!, Hope please provide any solution and let me know issue from code or from expo side … please confirm

My Android build’s splash screen is also freezing, I tried SDK version 24, 25

The same occurs with me, the android app freezes on splash screen. iOS app works perfectly.

I have same issue too. Seems to be expo build tool mass problem.

1 Like

Did you find a solution to this? I’m running into the same problem where I can tap around on the buttons that should be displayed, but are covered by the splashscreen.

Same issue here. It seems we need to hide splash screen manually if we use AppLoading

Thanks for the info everyone. Will take a look at this today.


Can people on this thread please share their code or a small example that reproduces this problem?

Did this work for you? for me it did not

I just tried a standalone build of this SDK 28 project which uses AppLoading, and the splash screen dismissed correctly for me:

I’m not sure what combination of features reproduces this bug, so please point me to a Github project where I can reproduce this.

no, it did’nt

It hapens on sdk 29

It hapens on sdk 29

Unfortunately this is not enough information for me to resolve the issue. It definitely doesn’t happen on all SDK 29 projects because I just tested one and it works. I want to help resolve this issue but I need a Github project that reproduces the bug first.