App Standalone Build Stuck on Splash Screen

Hello there! I’ve built an apk using expo build:android. The app works fine while testing in expo but the apk build gets stuck on splash screen and doesn’t proceed further. The splash screen seems to be reloading again and again. I’ve tried multiple rebuilds but the result is same.

I’m using Expo SDK 32.0.0 and I’m on windows. Any help would be SUPER appreciated.

Hey @effsociety,

Can you try running your project via expo start --no-dev --minify and see if that sheds some light on what might be causing the issue? Doing so replicates the environment that is run in production.


@adamjnav I’ve tried that. App runs the same way as without it.

@adamjnav any other suggestions about what should I do? I’m kinda stuck here.

You can try opening the .apk via Android Studio and running adb logcat to get device logs which are much more insightful than console logs. It may shed a light on what is causing the app to remain stuck on the splash screen.

Thank you @adamjnav I found the bug via the logcat. Strange that expo didn’t report it.

Glad you got it resolved! If you don’t mind me asking, what was the bug? Might be useful if other expo developers run into the same issue of their standalone getting stuck on the splash screen.

I’m using redux-persist and it seems that one of the reducers was returning something undefined.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.