Push notifications on iOS - Could not find APNs credentials error

  1. SDK Version: 35
  2. Platforms(Android/iOS/web/all): iOS

I am having some issues sending push notifications to a standalone app on iOS (expo with managed workflow).
Api or using expo push notification tool - with an already registered push notification token:

I am having this error

    "data": {
        "status": "error",
        "message": "Could not find APNs credentials for xxx.xxx.xxx (@xxx/xxx). Check whether you are trying to send a notification to a detached app. If not, you may need to clear your push credentials and regenerate or upload new ones.",
        "details": {
            "error": "InvalidCredentials"

I revoked all certificates on apple developer portal and cleared my push notification credentials and then built the app with expo build:ios -c. I am still having the same “InvalidCredentials” error.

  • Should I submit the binary in order to have the notifications working again ?
  • If not, should I wait some time in order to have the notifications working again after revoking the certificates with expo build:ios -c ?

Hi, I have same issue today. (in my case using expo 36)
I also revoked my credentials and re-built my app but not effective.

Then I realized Degraded Push Notifications was reported.
I’m not sure there is still some problems.

Anyway I found this comment in other topic.

So I reported about my status by email. @quinlanj
I hope I will get any response.

1 Like

Giving more details.

So I revoked all certificates on Apple Dev portal and then built the app using expo build:ios -c

I published a new version of the app + new binary to test flight. With this new version, I was able to have a new token (push notification)

But I am still having the same “InvalidCredentials” error when using it with expo push notification api

I have the feeling that I a m missing a step somehow

:raised_hands: Thanks,

I am still having the issue on my end. I have just tried again : revoking everything / rebuilding / publishing / and uploading a new binary to test flight , same InvalidCredential error
I will keep you posted if things change

I am having the same issue as well. I tried letting expo handle all certificates which did not work so we tried letting it handle everything but the push certificate and tried providing our own P8 file and key. Has anyone ran into this problem and found a clear solution? Most people online just said they rebuilt but that also did not work for us. Any suggestions would be extremely helpful.

Same thing happening with me

I am linking this issue here

it is similar to this one


Hello James, I found out that you have much context about push notifications, Can you help us our here?

Same thing happening with me since Friday.
I’ve also tried revoking all certs and using expo build:ios -c with no joy.

if i run expo fetch:ios:certs i get:
Push P12 password: (not available)

using SDK 35

This issue should be elevated.

I did 2 fresh standalone builds with SDK36 using own distribution certificates, push notifications keys and provisioning profiles. Both of them work properly in TestFlight, but push notifications are failing with the error Could not find APNs credentials for <bundleId>.

We’re looking into this now.


We’re looking into this now.

I’m glad to know expo team is exploring this issue.

Anyway I posted The Degraded Push Notifications was happened.
But it seems that it’s not related with this issue. Expo member said to me at email.

We’ve pushed a potential fix to this. We will continue to monitor the situation, please let us know in this thread if you continue to have issues.

Thanks for notifying us about the issue and your patience.


Push notification are working again on my both apps without any extra action.

Thank you for the good work!

1 Like

Many thanks :raised_hands: ! It is working now

Can we have some info regarding cause of the issue ?

1 Like

Working now for me too without having to re build my app.

Thanks :slight_smile:

1 Like

We are in the middle of reworking parts of our backend to increase reliability. There was a misconfigured return type in one of the helper functions we refactored.

1 Like

We also just posted a detailed post mortem here: Expo Status - New App Push Notifications Outage

1 Like

Thanks a lot!!
It works well now :+1:

Hey @jkhales, I’m still having similar issues with 2 apps on SDK 33. Just sent an email to secure@expo.io with the build urls