Could not find APNs credentials iOS Standalone

Please provide the following:

  1. SDK Version: 40.0.0
  2. Platforms(Android/iOS/web/all): iOS

When trying to send push notifications to a standalone iOS build device, I get the following error:

    "data": [
            "status": "error",
            "message": "Could not find APNs credentials for (xxx). You may need to generate or upload new push credentials.",
            "details": {
                "error": "InvalidCredentials"

I tried creating an entirely new Expo account, revoking all my Apple Developer credentials,
clearing all Expo push certificate keys, allowing Expo to handle certificates again, and also uploading my own p8 key file to expo servers.

Push notifications work fine on the Expo published apps.

Any help would be much appreciated. I’ve spent the last 3 days on this…



If anyone experiences the same issue, make sure that if you’re manually setting the experienceId in Notifications.getExpoPushTokenAsync({ experienceId: 'xxxx' }), it is in the format @expo_account/expo_projectname. That solved it for me.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.