InvalidCredentials: Could not find APNs credentials

Please provide the following:

  1. SDK Version: 41.0.0
  2. Platforms(Android/iOS/web/all):all
  3. Add the appropriate “Tag” based on what Expo library you have a question on.

Good afternoon.

Initially, everything worked and test messages came, the problems started after changed the Apple Push Key.

When I try to send a message via the expo notification tool on ios, I constantly get the message: InvalidCredentials: Could not find APNs credentials for ru.shoko.mobileStuffShoko (MB26A08FFE212). You may need to generate or upload new push credentials… I change the credentials generate new token and nothing happens.

It feels like my changes don’t apply on your side.

I updated the Apple Push Key, nothing changes, the error is the same.

If I run it through the Expo application, then everything is fine. push comes. If through my application I get an error.

Help plz.

update to sdk 44, nothing happened

Hey @devshoko, after you made the changes to the apns credentials did you rebuild your app? If not, you’ll need to do so.

Cheers,
Adam

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.