Could not find APNs credentials

Please provide the following:

  1. SDK Version: 35
  2. Platforms(Android/iOS/web/all): iOS

My push notifications were working perfectly yesterday. But today, when I was testing , I’m getting this response:
Could not find APNs credentials for host.exp.Exponent (XXX/XXXXX). Check whether you are trying to send a notification to a detached app. If not, you may need to clear your push credentials and regenerate or upload new ones.

I went into my developer account and noticed that my profile expired, so I removed that profile along with the the iOS Distribution cert and push notifcation key and allowed expo to build with the ‘-c’ flag. It built correctly (I allowed Expo to build new certs for me) and was published to the app store connect. When I tried to push another notification, I’m still getting the same error. Any help?

edit: When I tried to fetch my iOS cert with the expo cli command, the push p12 password is not available. Could this be an issue?. ALSO, when I checked out the App ID configuration/Identifier, I noticed that there was no cert associated with the push notification section, so I went ahead and created one on website. Should I have used that cert as the expo push cert during the expo build process?

1 Like

Hello, I have a similar issue as well. Any idea what happened?

No idea. It looks like its on expo’s side because a lot of people on this forum are having the same exact issues on iOS. Apparently notifications are still working on Android side so I’ll be testing that shortly. Hopefully the expo team will come out with a fix soon.

1 Like

I was experiencing the same problem and it started working again after a few days. I really wish Expo had replied with details on what happened and the fix.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.