Expo push notifications stopped working for transferred iOS app

Please provide the following:

  1. SDK Version: 40.0 bare workflow
  2. Platforms(Android/iOS/web/all): iOS
  3. “expo-notifications”: “~0.7.2”,

We’ve transferred our iOS app from personal to organization account recently. We realized after a few days that all our iOS apps stopped being able to receive notifications? The messages can be sent to Android with no issue.

We’ve then realized that there’s no way to change the Apple team ID in our old Expo account, not even uploading a newly created push cert with the new team worked. (It should, from Apple’s documentation, that as long as we don’t revoke the old push key it should still work on old apps, just new apps will need a new key in the new account)

We’ve then created a new expo account, hoping with the new setup + new certs, the new iOS builds will be able to receive notifications. But no, it still doesn’t work.

Can anyone help? All of our iOS users are affected. Thanks!

What’s the error message you’re getting back after trying to send a push notification to an iOS device? With the error message, you’ll get an idea of what’s going wrong