Notifications stopped working for iOS

  1. SDK Version: 35
  2. Platforms(Android/iOS/web/all): iOS

We recently updated our app from SDK 33 to 35. We did this in hopes that it would fix an issue where iOS 13 users were not receiving push notifs anymore on the existing app (sdk 33). We updated the SDK, but still had no notifications coming in when testing the app (on actual devices).

So I looked around the forums and found that re-creating the provisioning profile and ensuring that Push Notifications is checked seemed to be the solution.

So I deleted the existing provisioning profile, then let expo recreate the provisioning profile it when doing a build:

expo build:ios --release-channel prod-sdk35 --clear-provisioning-profile

I then uploaded this to test, but we are still not receiving push notifications. Even worse, now none of our users on the existing app are receiving push notifications.

I’ve tried sending push notifs manually through the testing tool, and it says it’s successful when sending to a user, but the user never receives it (example token ExponentPushToken[rzr23cHH9J9fFr1c0f9zyC]).

I’m at a bit of a loss as to what else I can try. It appears as though my certificates are setup properly with Apple, so I’m not sure what else I can do.

For reference here’s a post that I followed for recreating the provisioning profile. This fixed out inital issue (getting message from apple saying we’re missing :aps-environment" entitlement. But we’re still not receiving push notifications:

For others who came across this, the issue ended up being some stale token from Expo. Even when I deleted the tokens from our database it would re-issue the same token to the user. The only solution was for the user to delete the app, then re-install. Expo would then re-issue a new token which started working correctly.

Fortunately our app in one used only by a few dozen people, so it was easy to fix. Not sure what we would have done though if our app was more widely used and we couldn’t get people to re-install.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.