Expo Push notifications suddenly stopped working

Please provide the following:

  1. SDK Version: 35
  2. Platforms(Android/iOS/web/all): IOS Android

All of the sudden today expo stopped sending notifications to our production app. The notifications only do not send on IOS. Android is still receiving notifications. We looked and all of our notification certificates are correct and not expired. They were working earlier today, but stopped right when we needed them.
When we send out a notification, they send successfully with status code “ok”. I’ve tried using the notification tool and I am still receiving nothing. I’ve also tried to uninstall/ reinstall my app and got a new notification token and that still didnt work. I also cannot send notifications to my device throught the expo app debug mode.
The only thing we could find out of the ordinary was this when we tried running expo fetch:ios:certs

It was working three hours ago and then just stopped

We are having the same issue. Stopped around 1:20pm CST today and still not receiving messages. Testing tool is also not working with existing tokens. (i.e. ExponentPushToken[sTK2GpP8Kq_HeehWNmYUI9])

Are you able to send notifications to android?

Yes android is working fine for us.

Expo notification service says that everything is working, but clearly it is not. Are you running SDK 35

Yes we recently updated to sdk 35 in order to fix issue with push notifications on ios13. The update temporarily broke things, but after we remade our certificates everything started working again for a couple days until it stopped working several hours ago.

Let us know if you find a solution. We just tried the get receipts from expo, and we got receipts from android, ios is coming up blank.

Thanks for reporting this! We’re currently looking into it, and will keep you updated here

Fix has been pushed out, we’re still keeping an eye on it, but Notifications should be up and running

I can confirm that I’m starting to see notifications come in. Thanks!!

Guys, I know that problems happen. We have bugs all the time, but this is unacceptable. Our app has very time sensitive notifications and our users are extremely unhappy. We spent over 3 hours dissecting everything with notifications to figure out the problem and you status site said that everything was working. We expect that if there are problems on your end that we get notified.

Completely understand @davezp15, thanks for posting about this in the first place, and for putting your trust in us.

We’re working on a few solutions to make sure this doesn’t happen again, but we are very sorry for the inconvenience this has caused your team and your users


I have the same problem.
IOS seems to be working now, but Android not.
I am currently testing in with the Push notifications tool and only receiving on IOS but not on Android.

@resvevo I think you’re seeing a different issue, probably configuration related. We aren’t seeing any other evidence of a notification outage

Could be. Is if possible being a configuration mistake if the notifications show sometimes?
Some are coming through via the tool, some aren’t.

Could you elaborate on what you mean by “some”? e.g. does it always fail for a certain recipient while working for others? Or does it work for one recipient and then fail for that recipient and randomly work later for the same recipient? etc.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.