eas submit -p ios does not use uploaded App Store Connect API Key

We’re trying to use eas submit -p ios with a App Store Connect API Key that is uploaded in the “Credentials” section in the Expo web app.

We configured ascApiKeyId, ascApiKeyIssuerId, ascAppId and appleTeamId in eas.json, but it keeps asking for the ascApiKeyPath. Since we want to use the one uploaded to the webapp, there is no path because we don’t have it anywhere locally.

Is it possible to configure eas.json so that eas submit -p ios will pick up the App Store Connect API Key configured in the web app?

eas --version gives me:
eas-cli/3.8.1 wsl-x64 node-v18.14.0

hey there!

you can leave out the ascApiKeyId and ascApiKeyIssueId if you want to use the hosted version. if you provide those fields, eas-cli expects that you also want to provide a path to the key.

1 Like

Hey brents,

Thanks for your reply!

We tried with an empty submit configuration in eas.json, but that caused an Apple ID prompt and the goal was to have no prompt.

Then we tried with just ascApiKeyId, but that caused the ascApiKeyPath prompt.

So if I understand correctly, we only specify ascAppId and appleTeamId it should use the API Key that was uploaded? We will try that.

that’s correct. you can also skip the prompt by passing in --non-interactive

1 Like

That worked, thanks brents!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.