Can't open app with iOS simulator

expo-cli: 2.10.0
expo client app: 2.10.0
xcode: 10.1

I had some problems with the expo client app so I tried to run the app on a iOS simulator. I installed xcode and all required components. I tried to boot the app with i and it will boot up a simulator but it will not start or install my app on the simulator. I get the following error in my terminal and the status page:

I’ve searched for solutions on the internet and one thing seemed reasonable, to “Erase all content and settings”. Unfortunately this didn’t worked. Anyone else with a possible solution?

Hey @glenngijsberts,

Can you paste your app.json here?


Hey @adamjnav

  "expo": {
    "name": "darts-app",
    "slug": "darts-app",
    "privacy": "public",
    "sdkVersion": "32.0.0",
    "platforms": [
    "version": "1.0.0",
    "orientation": "portrait",
    "icon": "./assets/icon-darts.png",
    "splash": {
      "image": "./assets/splashscreen-darts.png",
      "resizeMode": "contain",
      "backgroundColor": "#73C700"
    "updates": {
      "fallbackToCacheTimeout": 0
    "assetBundlePatterns": [
    "ios": {
      "supportsTablet": true,
      "bundleIdentifier": "darts-scoreboard",
      "publishBundlePath": "ios/darts-app/Supporting/shell-app.bundle",
      "publishManifestPath": "ios/darts-app/Supporting/shell-app-manifest.json"
    "android": {
      "package": "d.a.r.t.s",
      "publishBundlePath": "android/app/src/main/assets/shell-app.bundle",
      "publishManifestPath": "android/app/src/main/assets/shell-app-manifest.json"
    "isDetached": true,
    "detach": {
      "iosExpoViewUrl": "",
      "androidExpoViewUrl": ""
    "scheme": "expae100ad8478d4358897a258cd1e68968"

Hope this helps, and thanks in advance :slight_smile:

It looks like you chose the Advanced option when creating the project with creates an ejected project that allows you to add custom native modules. If this is what you wanted, you need to build the project with Android Studio and Xcode. If that’s not what you want, you will want to create a new a project and select the Managed option which will allow you to run the project on a simulator without having to first build the project via AS or Xcode.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.