iOS - Simulator Download "app" is damaged and can't be opened

After following the steps found here building-standalone-apps-test-on-simulator
I “install” the app by dragging it over my iOS Simulator and the following alert window appears:

“{your-app-name}.app” is damaged and can’t be opened. You should move it to the Trash. The screen is also white.

The app works fine in Expo app within the iOS Simulator and on my device’s Expo simulator. It will load in TestFlight but will crash after I move into any screen. I was hoping to debug this via the Simulator…


      OS: macOS 10.15.2
      Shell: 5.7.1 - /bin/zsh
      Node: 10.13.0 - ~/.nvm/versions/node/v10.13.0/bin/node
      Yarn: 1.19.1 - /usr/local/bin/yarn
      npm: 6.4.1 - ~/.nvm/versions/node/v10.13.0/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
      Xcode: 11.3/11C29 - /usr/bin/xcodebuild
      expo: ^35.0.0 => 35.0.1
      react: 16.8.3 => 16.8.3
      react-native: => 0.59.8
      react-navigation: ^2.17.0 => 2.18.3
      expo-cli: 3.13.1```

see this thread: iOS Simulator Builds damaged error on MacOS Catalina · Issue #1197 · expo/expo-cli · GitHub

we’ll work on automating this soon! apologies

1 Like

That worked.

copied this from the link @notbrent posted above:

  1. Download simulator build as per link at the top of this thread.
  2. extract tar.gz
  3. open terminal
  4. run xattr -cr path/to/ (nothing will visibly happen)
  5. go back into Finder, drag & Drop the app you just ran the command on into your open simulator.
  6. It installs and click it to start.
1 Like

PS: This has not solved the fact that my TestFlight build does not work.

this is unrelated to testflight, you’d have to provide more info about what is wrong with your testflight build

This is only somewhat related but I think it may be useful if someone is on a similar track as I was with the above question. This article may help them further. Expo Crash on Standalone App only — How to Debug | by Taku | Medium

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.