White screen on standalone iOS build - New Issue

Opening a new thread for this as I’m sure none of the checks mentioned in the previous thread match the issue.


We’re not using Util.reload.

The build that we used in iTunes is now 10 days old, so it probably won’t have been affected by the recent issue mentioned here. The app also works fine in an Expo app, and the error mentioned is not the same.

On SDK 24 - we just got a white screen. On SDK 21 I’m now getting an error message

Error: undefined is not an object (evaluating ‘this._component.getScrollableNode’)
Status Code: 3

The timings coincide with the error mentioned here that was noticed 8 days ago - I would’ve built 2 days prior.

Update to this if anyone is having the same issue.

Narrowed this down to a problem with React Navigation. I’m very confused as, with the same code, same modules/sdk, this built/worked fine around ~12 days ago.

Again - all was fine in iOS simulator/iOS on Expo app - but going to a whitescreen on iOS when in testflight/production

When I downgraded to SDK 21, I got a more meaningful error rather than the white screen, and I then could see that the first screen was never being reached. I rearranged my routes (took out DrawerNavigator and used a StackNavigator as the base) and it was consistent in both platforms.

Hope this helps someone else, but I really don’t know how this worked at one point, and then didn’t work.

Seems like I have the same problem, spend the night on it, couldn’t find a solution yet.
I Have sdk 23, and I didn’t made any upgrade since more than a week.

This all expo thing is making me more problems at the end then it helps. Now I regret that I choose this path for making app, but anyway…

I’ve got same problem with white screen now, and I have no idea how to debug it or where should I start. In simulator, and in expo client app, everything works normal. But in standalone build for iOS I get white screen. Really frustrating this whole build process, and I’m struggling for few days now with iOS update.

This comment helped me. Good luck with that.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.