Unable to resolve module "AccessibilityInfo"

Hi there,

suddenly I’m receiving this error when loading the experience.
“Unable to resolve module ‘AccessibilityInfo’ from ‘…/react-native-implementation.js’: Module does not exist in the module map”.
https://github.com/facebook/react-native/issues/14209 suggests to rebuild node_modules but that does not work for me. Another hint is to update to react native 47. Is that possible with Expo? Has anyone had this error so far?


Problem vanished like magic after I changed the machine I’m building on.

I suddenly have been getting this problem too. Here’s the wierd part. I am on WIN10 and use Console2 for tabbed-command windows. It lets me pass in commands which I use to start up my nodejs, mongodb and expo services so I can do my development.

When I script the start of my expo service (“npm start”), I get this exact same error related to AccessibilityInfo on my Android, and my terminal windows shows “Failed building JavaScript bundle.”

However, if I manually open a command tab in Console2 or just use the plain old windows “CMD” to open a terminal and type “npm start”, it the app loads and the terminal window shows “Finished building JavaScript bundle in 978ms”

The only thing I can think of is that I tried installing react-native-pdf following these instructions shortly before it started getting loopy on me last night. The instructions had some command that linked react-native-pdf to react native. But that doesn’t explain why it works in a non-automated command terminal vs. one that automatically fires up the npm start command.

As a postscript to my post (sorry…couldn’t resist) I changed my startup on Console2 from “cmd.exe /K npm start” to go.bat, with go.bat simply running “npm start”. Now it fires up like a champ again. I am still at a loss as to why it stopped working in the first place, but perhaps knowledge of this nuanced behavior on my dev box will help someone else. Since@quape also saw it working just fine on one environment and not another with no apparent reason for the change, it definitely feels like more of an environmental issue than an actual code issue.

Oh well about a 12 hours of development opportunity cost down the tubes on this one, but no longer feeling queasy about my react-native endeavor.

Ok, one last post…After I was back on solid ground, I backed up my app folder and verified I could run the app from the backup. Then I re-tried the install of react-native-pdf. I was back in hell. I blew away my app directory and copied from the backup and still was getting the AccessibilityInfo problem. It was a problem regardless of the teminal (windows command, console2, with auto-start, without autostart. ) The backup kept working but I could not get the main app directory to work. I even deleted the main app directory and recreated it to make sure nothing wierd happened to it and verified that the file/byte count was identical. So it had to be something outside of my app.
Next I cleaned out my AppData\Temp folder. And Viola! Back in business again. I’m not sure what kind of yuck was put into the temp folder but that seemed to clear this error message up. I’d love to keep trying to nail this one down, but I have “real” work to do and I’m about 2 days behind now. Hopefully someone can shed some light on a less barbaric way to resolve this in the future.

I’ve been having the same problem on OSX. At first it was happening seemingly at random, now it happens all the time and i can no longer open my application. I’ve tried deleting node_modules a bunch of times and tried reinstalling with both yarn and npm v4.6.1. That does not work. I’ve tried all the suggestions expo logs out to me, but nothing seems to work.

I’m now encountering this issue at the end of my project when I’ve finally built my binaries. Are there any updates on a fix for this?