Expo SDK v33 Error on expo start

Hello trying to get up and running with Expo SDK v33 and keep running into the following error upon attempting to run expo start --<platform>.

Error: Unable to resolve module ./node_modules/expo/AppEntry from <project path>/.

I can see the AppEntry.js file under the node_modules/expo directory, so I don’t understand the reason why metro throws this error under ModuleResolution.js:160.

Am I doing something wrong? I followed instructions step by stephere anyone running into this same issue?

Upon further investigation and tailing the error I see:

{ Error: The module could not be resolved because none of these files exist:
  * `<path>app/node_modules/expo/AppEntry(.native||.ios.ts|.native.ts|.ts|.ios.tsx|.native.tsx|.tsx|.ios.json|.native.json|.json)

expo directory doesn’t generate any of the indicated extensions above. Could this be the problem? if this is the case is anyone else having issues with SDK v33 or am I doing something terribly wrong?

Hi @stephenotalora! What SDK were you upgrading from?

I had the same issue. My solution was to add the js extension to the packagerOpts.sourceExts array in the app.json file. I only had ["ts", "tsx"] in there, but after changing it to ["js", "ts", "tsx"] the error disappeared and my app built again.


@charliecruzan upgrading from SDK v32

@remcorakers, @charliecruzan I tried adding adding js as part of packagerOpts.sourceExts and I keep getting the same error.

this is what I get back:

Error: Unable to resolve module `./node_modules/expo/AppEntry` from `<fullpath>/admin-app/.`: The module `./node_modules/expo/AppEntry` could not be found from `<fullpath>/admin-app/.`. Indeed, none of these files exist:
  * `<fullpath>/admin-app/node_modules/expo/AppEntry(.native||.ios.js|.native.js|.js|.ios.ts|.native.ts|.ts|.ios.tsx|.native.tsx|.tsx|.ios.json|.native.json|.json)`
  * `<fullpath>/admin-app/node_modules/expo/AppEntry/index(.native||.ios.js|.native.js|.js|.ios.ts|.native.ts|.ts|.ios.tsx|.native.tsx|.tsx|.ios.json|.native.json|.json)`

note that is looking for the following file extensions for AppEntry:

however a non ejected expo app has just ./node_modules/expo/AppEntry.js I suppose |.js| should work now however I keep getting the above error in addition to the following on iOS:

Okay finally figured it out. had an issue with monorepo and symlinks. thanks for the help everyone :pray:

1 Like

@stephenotalora can you clarify what solved it? I’m running into this as well.

@buishi are you on a monorepo project structure?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.