Unable to find module for DevMenu

When I am trying to run my app through Expo QR code or “npm run ios” command line (tried with all available option to run ios build), I am getting an error saying “Unable to find the module for DevMenu”.
Also tried with expo eject.

Can anyone help me with this?

1 Like

can any one gone through same issue?
I am trying to build and run app on iOS simulator but getting this issue.

Also running into this issue. Help?

Saw this from here and was able to fix my issue. My Podfile and AppDelegate files hadn’t been updated: https://github.com/unimodules/react-native-unimodules/blob/master/README.md

I think the error occurred because I upgraded a bare app from SDK36 -> SDK37.
Un-ejecting and re-ejecting while already upgraded to SDK37 fixed the issue for me.

I’m guessing un-ejecting and re-ejecting would be the smoothest way to upgrade expo SDKs. I’m just starting to work with expo again and it seems to me like that’s the fastest and easiest way to avoid any random errors.

For me this issue is happening when I update Expo. Im using a managed app so not sure what the problem would be / how to fix.

2 Likes

Anyone found a fix for this annoying issue ?

It almost happens after every reload, tired of it. I enabled “remote debugging” and also receiving “Runtime is not ready for debugging” after this error.

Make sure you are not importing anything which you haven’t exported

Same issue with expo: ~39.0.2

Anyone find a real solution to this issue or to the “Runtime is not ready for debugging” error? So annoying.

it sounds like you have remote debugging enabled and chrome is closed

Still facing the same issue when keeping the React Native Debugger page open on Chrome. Does anyone have an update on a possible solution?

what if you disable the debugger and turn it back on?

1 Like

Also running into this issue. Disabling and re-enabling debugger doesn’t work, using Chrome or React Native Debugger still has the issue pop up. It renders the app unresponsive. Only fix is to close and restart sim.

I have also tried “Erase all content & settings” and using a different sim device.

Am using the managed workflow and sdk 39.0.5.

if this is happening in an ejected/bare react-native app it seems like this is likely to be an upstream react-native issue, you could look on the react-native github issues to see if others have had similar problems. i haven’t encountered it personally

I did disable the remote JS debugger on Chrome and turned it back on, but it did not work. I kinda got annoyed with myself wasting whole day without progress so I went have a cup of warm milk and screamed for a few seconds at the balcony. When I came back I somehow found a workaround - instead of debugging on Chrome, if you use the application of React Native Debugger, the app starts functioning as normal.

And then I closed the application and come back to use the debugger on Chrome again. I got the same error with frustration, and then I hopelessly refreshed the app again. Somehow all started working from there.

Since then, I still occasionally got the same error. When this happens, what I need to do to get it back to function is to turn off expo, then restart expo, and finally relaunched the app in the simulator.

Hope this is helpful in any way. If anybody could have a more well-rounded solution to this issue, I would love to learn it! :grin:

Running into the same thing. Not even the warm milk helped.

post some info if you want to some help :stuck_out_tongue: expo diagnostics in your project

Fair enough, I suppose my previous post didn’t offer much to go on.

> expo diagnostics

Expo CLI 4.0.17 environment info:
    System:
      OS: macOS 10.16
      Shell: 5.8 - /bin/zsh
    Binaries:
      Node: 14.15.0 - /usr/local/bin/node
      Yarn: 1.22.10 - /usr/local/bin/yarn
      npm: 6.14.10 - /usr/local/bin/npm
    SDKs:
      iOS SDK:
        Platforms: iOS 14.3, DriverKit 20.2, macOS 11.1, tvOS 14.3, watchOS 7.2
    IDEs:
      Xcode: 12.3/12C33 - /usr/bin/xcodebuild
    npmPackages:
      expo: ^40.0.0 => 40.0.0
      react: 16.13.1 => 16.13.1
      react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2
    npmGlobalPackages:
      expo-cli: 4.0.17
    Expo Workflow: managed
# ~/.zshrc
[...]
export REACT_DEBUGGER="unset ELECTRON_RUN_AS_NODE && open -g 'rndebugger://set-debugger-loc?port=19001' ||" yarn start

App works on simulator when not debugging, but when I enable remote debugging, React Native Debugger launches as expected, but the app hangs at 100% for a few seconds, followed by a red banner: Unable to find module for DevMenu, followed a few second later by a new red banner: Runtime is not ready for debugging...

Oddly, when I remove the REACT_DEBUGGER env variable, the chrome debugger does run successfully EDIT: False alarm. Worked once, then on next refresh I get the same errors.

EDIT: I have tried erasing content and settings on simulator, clearing node_modules and yarn.lock, and started with expo start -c with same results.

does this happen on a new blank project as well? if not, can you share your project on github? my username is brentvatne

1 Like