[Broken build process] SDK34 ejected - "Unable to find module for DevMenu"

I’m trying to solve the “Application main has not been registered” issue (Expo does not find “main” application in production build) with SDK34 ejected app.

As suggested by some, I tryed to build from scratch with react-native init appName --version react-native@0.59.8
Of course I felt into the https://github.com/facebook/react-native/pull/25146/files#diff-263fc157dfce55895cdc16495b55d190 issue, but if I use expo’s react-native I expected this to be solved.
I put a minimal version based on my app in this new repo and now I have this brand new error :slight_smile: “Unable to find module for DevMenu”

I very disappointed by the lack of paid support, I’ve asked companies mentionned in expo.io/consultants, only one responded but with a nice profile but who want me to get rid of Expo. Shall I follow his advice ?
Or is there someone at Expo that can handle the initial issue and allow me to identify what prevents me to build and test this app on TestFlight.
FYI I already have another app published on the AppStore (ejected sdk34 also), so I know and practiced the full process on the same environnement. All is cleaned up with watchman, rm -rf TMP… I did exactly the same but it fails for this one. I want to find why and how to fix it.

sdk34 expokit or bare app?

you can use react-native@0.59.11 to fix that issue you linked to from the react-native repo. this is the version we use for bare ejected apps.

also, who was the agency that you spoke with?

sdk34 expokit.
I solved the initial issue so I won’t investigate more.
I won’t answer to your question here about who was the agency, but I can tell it is not OK Grow as they decided to shut down, so you can remove them from the list.

feel free to email me brent at expo dot io

If I use react-native init project, but i use the ExpoKit 34
Unable to find module for DevMenu
Hot to fixed it?