Standalone doesn't receive updated js. But using QR does.

Sup. Im noob,

I have a standalone and a published url.
Problem is that when i run the standalone on a device the app doesnt update the new js. I think so cause opening the app using an expo QR runs the code just fine.

Expo CLI 4.0.17 environment info:
OS: Windows 10 10.0.18363
Node: 12.18.3 - C:\Program Files\nodejs\node.EXE
Yarn: 1.22.4 - C:\Program Files (x86)\Yarn\bin\yarn.CMD
npm: 6.14.6 - C:\Program Files\nodejs\npm.CMD
expo: ^40.0.0 => 40.0.0
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
Expo Workflow: managed

Hey @rushhhn, if you haven’t configured your updates settings in app.json your standalone app is likely set to 0 milliseconds which means it will instantly launch with the bundle it had last downloaded. If you close the app and re-open it, you should see the JS updates take effect.

You can increase the wait time by following these docs:


Greetings, adamjnav.

The update indeed was set to 0ms. I increased it to 30k and 300k after that. No avail.

After reopening the app multiple times - same behavior: jsx gets updated but not js.

My js code is a 1-liner: fetch(‘http://example/push_notifications.php’, {method: ‘POST’, body: JSON.stringify({ token })}) inside the registerForPushNotificationsAsync by expo push-notifications.

As i said the code above works in the published version of the app. However the standalone seems to ignore this update.

Problem solved. OTA updates work as adamjnav described.

Thing is that I identified the problem incorrectly from the start. My issue was not related to broken updates but expo-notifications.

What I did wrong was not setting up credentials for Android as laid out in the guide: Push Notifications Setup - Expo Documentation


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.