[SOLVED] Difficulty creating projects seems like it's a DNS problem

Hi there. My first baby steps with XDE have been frustrating.
Several things simply do not happen and I keep waiting for ages… and nothing happens.

After some investigation, I found that some resources are served by cdn.segment.com which apparently vanished from existence. It’s a DNS error pointed out by this error message:

Failed to load resource: net::ERR_NAME_NOT_RESOLVED  analytics.min.js

Had anyone observed the same behavior?

I’ve tried some other things TL;DR until I finally had the idea of removing dependencies from cdn.segment.com, if that would be possible and easy for a complete newbie like me.

For my surprise (and relief!) there are no occurrences of “segment.com” in the sources of XDE in github/master. So, I’ve reverted my Node version to the recommended 6.2.2 and built XDE from sources.

The result is that now I don’t see DNS failures anymore and after some more stupidities a newbie always do… well… I was able to run the application in XDE and share to Expo running on my Android phone.

So, the solution is: build XDE from sources, Luke!

1 Like