Cannot run old or newly created expo projects in XDE

For a school project I am using bitbucket for the first time as a repository for a react-native expo project. I just cloned the project repo that my partner has been working on to my local machine and tried to start it in expo to test it in the expo client on my phone. When starting up the expo XDE I got an error stating I needed to run npm install in my project directory, which I have done before on other noncloned projects after adding new npm modules, so I went ahead and ran it.

This time after I ran npm install I got a couple warns one involving babel but did a quick google search and from what I saw I thought I could just ignore it and move on. Unfortunately now all of my expo projects will not run in the XDE. At first I thought it was just that cloned project so I went searching for an answer about how to install that babel peer dependency but couldn’t find an answer. I decided to take a break and look at one of my other expo projects and now that one is having the same issues as the cloned project even though I have changed none of the code and the only thing I have done in general is download the project from bitbuckets repo, changed a few files that had typos that were not updated on the repo, and then run npm install.

When I run any project in the XDE (even one I just created to test) I see:

Starting React Native packager…
4:33:10 PM
Scanning folders for symlinks in C:\Users\digio\Documents\Expo Projects\connectiontest\node_modules (61ms)
4:33:11 PM
Loading dependency graph.
4:33:11 PM
4:33:11 PM
4:33:11 PM
Project opened! You can now use the “Share” or “Device” buttons to view your project.
4:33:11 PM
Switched to a LAN URL because the tunnel appears to be down. Only devices in the same network can access the app. You can restart the project to try reconnecting.
4:33:26 PM
Dependency graph loaded.

and on the expo client app I get a message stating that:

There was a problem loading the requested app.
Try again
Go back to Expo Home
Could not connect to the server.

I’m honestly not sure where this issue came from since it is affecting all of my projects in the same way. Just in case it is related to the warning I got when I ran npm install this is the warn I received:

npm warn @babel/plugin-check-constants@7.0.0-beta.38 requires a peer of @babel/core@7.0.0-beta.38 but none is installed. you must install peer dependencies yourself

But like I said I did not get this warn on my other projects and they were running fine before this issue showed up when I tried to run the project I cloned from my bitbucket repo. I am not sure where to go from here since I am still very new at expo and react native.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.