Error when running newly created project on expo XDE

So I downloaded expo, tried to create a new project off the blank template and ran into the problem of the files never extracting. Read through through forums and the tried running the xde as administrator which fixed the problem and created the project succesfully.

Upon running my newly created project i get the following error:

Project opened! You can now use the "Share" or "Device" buttons to view your project.

Error: ENOENT: no such file or directory, open 'C:\Users\Chris\AppData\Local\Temp;c:\ffmpeg\bin\haste-map-react-native-packager-1-62f365747c707e70e740305179cd0617'

I have tried:

  • unistalling and reinstalling xde

  • downloading a zipped template and extracting and using that template(also throws error)

Unsure about what I am missing here.

I have previously installed nodejs (currently have v6.11.0) not sure if that would impact at all?

Hi! Sorry to hear that you’re having problems running your project. Can you tell me what the contents of your PATH environment variable are?

Thanks for the reply!

There are a couple more path system variables, but these seemed most relevant.

PATH SYSTEM variables
C:\Program Files\Git\cmd
C:\Program Files\Microsoft DNX\Dnvm
C:\Program Files\Microsoft SQL Server\130\Tools\Binn
C:\Program Files (x86)\PuTTY
C:\Program Files\Intel\WiFi\bin
C:\Program Files\Common Files\Intel\WirelessCommon
C:\Program Files (x86)\Skype\Phone
C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit
C:\Program Files\nodejs\

PATH USER variables

Interesting! If you press View->Toggle Devtools, can you expand any errors there and screenshot those?

Can you tell me what the value of the $TMPDIR environment variable is on your machine?

I do not have any environment variables TMPDIR but have TMP ones, are these what you mean?

TMP USER Variable

TMP System Variable


I have managed to find a fix and can now run my app succesfully.

After trying to create React-native apps instead and running into problems there I found these:

I had two TEMP USER variables set, of which I removed one.
I changed the TEMP SYSTEM variable’s value to C:\temp.

This seems to have fixed my problem.

Thanks for the help @dikaiosune!

1 Like