[SOLVED] Can't debug app with SDK 49

Hi! I’m using Linux Mint 21.2 and having a hard time to get hermes debugging working. My workspace is as follows:

  • Linux mint 21.2
  • WebStorm 2023.1.4
  • Using expo sdk v49 (49.0.6)
  • Expo Go on iPhone 12 Pro Max and iOS 16.5.1

For testing hermes debugging I have created a complete new and clean app with npx create-expo-app@latest --template tabs, I have also uploaded the app to GitHub here GitHub - mgscreativa/heremes-test-expo-go: heremes-test-expo-go

Accessing chrome://inspect I can see the hermes instance running but I can’t see anything to debug in there. Have attached a video showing the process I’m following

Peek 2023-07-31 17-23

What Am I doing wrong? Should I configure enything else?

PS: Flipper 0.209.0 not even shows my iPhone at all

Finally found the issue. It seems that I have created a conf file in sysctl.d /etc/sysctl.d/99-disable-ipv6.conf, inside I had set

# Disable ipv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

So reverting net.ipv6.conf.lo.disable_ipv6 to 0 solved the issue at startup!

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.