React Native Packager Hangs (Proxy related)

Hi, I just installed XDE, and fololwed the up and running steps. Tried to create a new project and run via the expo IDE. It hangs in “Starting React Native packager…” after the line “Dependency graph loaded”. If I visit the url I get the following error {"error":"XDLError: ValidationError: child \"urlRandomness\" fails because [\"urlRandomness\" must be a string]"}

I’ve successfully created and run CRNA before using the expo client. As additional info I am behind a corporate proxy. I have HTTP_PROXY, HTTPS_PROXY, ALL_PROXY set, and my npm and git installations have the proxy configured

If I disconnect from the corporate proxy, and connect via an LTE sim I don’t have that issue. It did prompt for windows firewall exceptions, which were not prompted for on the corporate proxy

For further information. If I disable HTTP_PROXY on my machine, I can start the react native packager, however I then unable to publish/share correctly.

1 Like

I’ve fixed this one of two ways.

  1. If I’m debugging locally, change the Host type to LAN and everything works.
  2. If I’m tunneling, open the settings.json file in the .expo folder and add quotes around the urlRandomness property. By default it is set to null, it worked for me by changing it to “null”.

Is there any way to start the xde development server locally only?
I can get ngrok to work on my machine, when I run in a separate command prompt window) and I guess I would then be able to forward the locally running dev server from behind the corporate proxy.
I’ve tried using both the desktop and cli for xde and can’t seem to get it running behind a corporate proxy.
I am using windows.

I have this same problem still occuring almost 10 months later!! (I started fresh today)

What exactly do you mean by “change the Host type to LAN and everything works.”?

I realise this is 10 months later, but I’ve run into this error on multiple macs now and yet somehow I’m the only still getting it I would really appreciate your help.

I tried putting the quotes around null like you said, and also that did SEEM to work, as soon as the simulator runs I see this in the simulator screen:

“:There was a problem loading the requested app. It looks like you may be using a LAN URL. Make sure your device is on the same network as the server or try using a tunnel.”