Default settings throwing error

Hi all,
Firstly, I’d like to admit I’m completely new to expo.

I’ve followed instructions from, which recommends using expo.

I’ve created a new app, as per the instructions, and ran it using the suggest command.
My console prints a QR code and explains that the app is viewable at //
When I attempt to view the app in a browser, I’m hit with a message stating;
{“error”:“XDLError: ValidationError: child “urlRandomness” fails because [“urlRandomness” must be a string]”}

I’m almost convinced this is an issue caused by expo, because I remember have the exact same physical set up about a year ago and creating a react-native app without expo, and being able to successfully view it in a browser. (But I obviously cannot confirm this, as my experience with both react-native and expo is extremely limited.)

From expo installation to app running, the only commands I’ve entered are;
npm install -g expo-cli
expo init default_project (I chose tabs from the option, previously chose blank, made no difference.)
cd default_project
npm start (which forces the use of expo)

If it makes any difference, the app has been installed and ran on a raspberry pi on my local network, accessed via ssh. (I’m attempting to view in a browser on my windows 10 PC, which worked a year ago when not using expo.)

Can anyone please shed any light on the error message returned in the browser, or what could potentially be wrong with my default setup?


Done some further searching, the only thing that’s made even the slightest difference was another thread on these forums.
React Native Packager Hangs (Proxy related)
The OP had the same error as me, but a slightly different set up.
I’ve followed one of the comments that recommended updating the value for urlRandomness in .expo/settings.json to be encapsulated with quotes.
Doing this and then launching the project returns a different error.

{"name":"default_project","description":"A very interesting project.","slug":"default_project","privacy":"public","sdkVersion":"31.0.0","platforms":["ios","android"],"version":"1.0.0","orientation":"portrait","icon":"./assets/images/icon.png","splash":{"image":"./assets/images/splash.png","resizeMode":"contain","backgroundColor":"#ffffff","imageUrl":""},"updates":{"fallbackToCacheTimeout":0},"assetBundlePatterns":["**/*"],"ios":{"supportsTablet":true},"xde":true,"developer":{"tool":"expo-cli","projectRoot":"/home/pi/shared/default_project"},"packagerOpts":{"hostType":"lan","lanType":"ip","dev":true,"minify":false,"urlRandomness":"null"},"env":{},"bundleUrl":"","debuggerHost":"","mainModuleName":"node_modules/expo/AppEntry","logUrl":"","hostUri":"","iconUrl":""}

I’ve attempted to google even parts of this error, and haven’t found anything that seems to be relevant.
Does anyone know what could potentially be causing this, or how to resolve?

I am also facing this issue on Raspberry Pi, were you able to solve it?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.