Exp-cli and Exp xde Packager hanging/stalling right after "Dependency graph loaded." step

The packager is hanging/stalling right after the “Dependency graph loaded.” step. This happens in both the CLI and XDE. Can someone please tell me what the problem could be? I’m using npm v4.1.6 and node version 9.

Try exp r -c (which clears your packager cache).

It’s still not working. Here is what is being output after running the above command:

⇒  exp r -c
09:38:19 [exp] Using project at /private/var/www/react/oo-react-app
09:38:27 [exp] Starting React Native packager...
09:38:28 [exp] Scanning folders for symlinks in /private/var/www/react/oo-react-app/node_modules (8ms)
09:38:28 [exp] Loading dependency graph.
09:38:29 [exp] Dependency graph loaded.
Stopping packager...
Packager stopped.

I’ve tried uninstalling and reinstalling the expo xde, also the expo cli. I’ve also tried all of the steps here: How to clear the Expo and React Native packager caches (Metro, Watchman, Haste) without any luck.

Any help on this would be greatly appreciated. Let me know if you need logs or anything.

Can someone please help with this? I’m getting no where.

Are you sharing or pushing to a device after the dependency graph is loaded?

I’m not able to get that far. The development server doesn’t seem to start. My project works fine on my home Mac, but the same source code, versions of npm and node, do not work on my office Mac. At home I am getting messages from the terminal that say:

Loading dependency graph.
Tunnel connected.
Expo is ready.
[bar code]
Your URL is: …
etc. etc.
Dependency graph loaded.

But on my work Mac, these messages are omitted between “Loading dependency graph” and “Dependency graph Loaded”

Thanks for your help in advance

I work with Expo on a PC, so I don’t think I can be of much help. Sorry.
However, have you tried pushing to the device by pushing that button in the XDE? Or scanning the QR code in the XDE with your device.
For me, on a PC, the dependency graph loaded message is the point where I can successfully load the project on my device.
As for the difference between work and home, I’m assuming you’ve checked your XDE and CLI version on both machines.

Thanks for the quick response. I’ve checked that all versions are the same. It may have something to do with the Tunneling? The problem is that the QR code isn’t appearing in my terminal for me to push it to a device, also, in the XDE, the button to push to a device is greyed out.

I’ve never seen that situation before. Hopefully, someone from the Expo team can help out.

Can anyone else chime in? It’s still an issue. Potential problems with my network, etc?

Hi @jogillesp - sorry for the lack of response here. Can you make sure you’re on the latest version of exp (npm install -g exp)? And have you tried the different network options (e.g. exp r --localhost)? Also, you might try running EXPO_DEBUG=true exp r to see if any extra information shows up.

@fson - do you have any other ideas about this?

I updated exp, and now I get this:

EXPO_DEBUG=true exp r
14:59:57 [exp] Using project at /private/var/www/react/awesomeapp
15:00:09 [exp] Starting Metro Bundler on port 19001.
15:00:09 [exp] Metro Bundler ready.

With nothing after.

I’ve also tried the different network options with no luck. Would the diagnostics from the help menu in XDE be of any help?

hmmm, @fson may be able to help more, but since it looks like you upgraded from a pretty old version of exp, it might be worth trying all of the steps in that “How to clear the React Native packager” link you posted above, again.

I just started having trouble with this on my work laptop. It was working fine up until Friday…

I’ve tried a number of things, including all of the steps listed here: How to clear the Expo and React Native packager caches (Metro, Watchman, Haste)

Recently noticed in ~/.expo/log :

"msg":"No packager found for project at path-to-my-project.",

Not sure what to do next!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.