Publish with no effect

Hello there,
First of all, many thanks to the expo team for all your great work, you make my life much easier.

I have an app still running on sdk17, it’s a detached app, since it was put to the app store I did bunch of publishes through xde and all worked fine, last was on Feb. 16th.
Now I had to add new feature, which I did, but now after publishing, installed apps do not load new js, they still load old js bundle without my new feature.

Any pointers why?


Hey @danijel,

What kind of changes did you make to your app? Some changes require you to rebuild your binaries and submit to see updates take effect.

Side note: Can you try opening and killing your app a couple times to see if that causes the updated JS bundle to be fetched.



Hey @adamjnav ,
I just added one more screen/form, nothing to require new ipa/apk build.
I tried bunch of kill/open bunch of times, I also tried remove and install from app store again.


The bundle loading policies for the server & client changed significantly over the past year. It’s difficult to say what the issue with SDK 17 is. The best advice I can provide is to update your app to work with SDK 25 and submit new versions to the App Store and Google Play, and regularly stay up to date.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.