Publish command not updating specific release channel


I have an iOS standalone app in TestFlight. There are 2 versions, 1.1.3 and 1.1.4, with release channels staging and prod respectively. Both these versions are using Expo SDK 27. When changing to version 1.1.3 in app.json, and running exp publish --release-channel staging the app updates as expected. However, when changing to 1.1.4 in app.json and running exp publish --release-channel prod nothing seems to update in that version.

I have tried using -c as an option, closing and opening the app (as required by OTA updates), deleting the app, and running exp start with the version change first then running publish.

Note, the only app.json changes, besides the versions, have been android configs, so this shouldn’t affect the iOS build, right?

Any help would be greatly appreciated.

Hey @brendanvadacorabell,

What changes are you making? You thing to make is that certain changes (mostly changes to app.json) can not be updated via publishing.



Hey @adamjnav ,

All changes are UI changes in JS. The only app.json changes were for android so shouldn’t affect the iOS build. Also wouldn’t explain why release channel staging worked while prod still doesn’t.

Thanks for the thought though.

Just wanted to double check for clarification. We also have replaced the exp CLI. It’s been replaced with the expo-cli for some time now. Could you try installing that via npm install -g expo-cli and run the publish command and let me know if that works?

@adamjnav thanks for the suggestion. I used expo-cli on the same release channel, prod, but with new builds and that seemed to work. Hopefully that’s the solution. I’ll test on the original build causing issues, 1.1.4, and if it still doesn’t update will post here again.


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.