Not getting console log with expo-cli on iOS 12.1.4 / iPhone 7

Weird issue to report here, but hoping someone can help shed some light on what’s going on.

I’m using an iPhone 7 on iOS 12.1.4 (latest), have the latest Expo client version 2.10.0 installed, and Expo CLI version 2.10.0 (also latest). My app is on SDK 31 (one back from latest).

As of a few days ago, I no longer see any of the console log statements in terminal anymore after starting the app up with expo start. I’ve tried several of my active projects on two different Macbooks and I’m not seeing the console log statements.

However, I was able to get the remote JS debugging running and console log statements showed up in the Chrome console. Also, when I ran all the various apps I have on an iOS simulator, the console log statements did show up in terminal.

This makes me feel that this has something to do with the physical device / Expo client on the physical device. I tried deleting and re-installing the Expo client on my iPhone and that didn’t do anything. I checked for all possible settings that I could have accidentally toggled and couldn’t find any. Having to work through remote JS debugging really lags my computer so I would really like to find a way to bring back the console log statements to the terminal. Thanks for any help.

Hey @ilyaus,

Can you check two things for me?

  1. Create a new project and see if the console.logs still do not appear
  2. Ensure you only have one window of the expo-cli GUI opened in your browser


Hey @adamjnav,

As requested, I created a brand new project using expo init. I did not toggle any of the default settings. Initially, I tried without even having the Dev Tools open in the browser, and then again with one, and only one, Dev Tools window open. Like before, I did not get the console log messages in Terminal. The console logs messages were also not present in the Expo Dev Tools window. I also tried to rollback expo-cli to 2.8 and 2.7, but that didn’t produce the console log statements in Terminal.

I then tried the remote JS debugging, and like before that produced console logs in the Chrome console. Opening the app in the iOS simulator also did indeed produce the console log statements in terminal. So this was the same as before.

Process of elimination is telling me that it’s either something specific to my device (what could it be?) or something specific to the Expo client that’s running on my device. The last time the client was updated on the apple app store was 1 month ago, and I didn’t have the issue then. Are you aware of all OTA pushes that were made to the official Expo client that could be related to this in any way?

@adamjnav quick follow up – I tested this morning with a colleague’s iPhone XS and the console logs did show up from his device. Now I’m super confused. What local settings on my device could I have messed with to cause this?

@adamjnav Ok I realized what local settings I messed with and was able to revert. It was the name of the iPhone (Settings, General, About, Name). I had changed the name of the iPhone to include ASCII special characters (e.g. ♫♪.ılılıll|̲̅̅●̲̅̅|̲̅̅=̲̅̅|̲̅̅●̲̅̅|llılılı.♫♪). Once reverted back to “iPhone”, the console logs started to show up again. Would we call this a bug that console logs don’t come through when you have special ASCII characters in your device’s name?


Thanks for the detailed follow-up! I think we should definitely make sure we handle the ASCII special characters case better. Would you mind creating an issue detailing it here: If you don’t have the time, I can get around to it as well!

@adamjnav Sure, just submitted here: Feel free to bring it up to the team. Guess this means I can’t live my fantasy of having a fancy ASCII art iPhone name now :sob:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.