Installation doesn't finish


I’m currently making application with expo and “create-react-native-app” produced by facebook,
I typed the code “create-react-native-app PROJECT NAME” on terminal, though the installation
has been stopped while checking installable status.

The problem is like the picture below.

Is there any way to solve this problem?

expo-cli version: 2.6.14

Thank you.

Hey @dos-project,

CRNA has been deprecated in favor of the expo-cli. Can you try running expo init PROJECT-NAME and see if that works? If it doesn’t, can you run expo diagnostics and paste the log printed out here?



1 Like

Hi @adamjnav,

Thank you for your reply.
I tried expo init PROJECT-NAME, though unfortunatelly it throws error.

npm ERR! code 1
npm ERR! Command failed: /usr/local/bin/git checkout expo-font-fix
npm ERR! error: pathspec 'expo-font-fix' did not match any file(s) known to git.
npm ERR! 

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/kentaishii/.npm/_logs/2019-01-05T00_25_31_262Z-debug.log
[09:25:31] Process exited with non-zero code: 1
[09:25:31] Set EXPO_DEBUG=true in your env to view the stack trace.

Also I’ve done expo diagnostics and this is the result.

  Expo CLI 2.6.14 environment info:
      OS: macOS 10.14.2
      Shell: 3.2.57 - /bin/bash
      Node: 10.9.0 - ~/.nodebrew/current/bin/node
      npm: 6.5.0 - ~/.nodebrew/current/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
      Android Studio: 3.2 AI-181.5540.7.32.5056338
      Xcode: 10.1/10B61 - /usr/bin/xcodebuild
      expo-cli: 2.6.14

Thank you,


apologies, that was an intermittent issue, it is resolved now - give it another go

1 Like

Hi @notbrent

Thank you for you reply.
I got it. I retry it a few more times.

Thank you,

DoS Project

Thank you.

I finally solved an error and succeeded!

How can I close this issue?

I’ll close it for you!

1 Like