Error: React Native is not installed. Please run `npm install` in your project directory.

Running npm install doesn’t help

node v8.9.1
npm v6.4.1 (upgraded from v6.1.0)

I’m currently having the same problem.

expo v2.6.8
node v8.9.4
npm v6.4.1

Expo CLI 2.6.8 environment info:
      OS: macOS 10.14.1
      Shell: 5.3 - /bin/zsh
      Node: 8.9.1 - ~/.nvm/versions/node/v8.9.1/bin/node
      Yarn: 1.12.3 - ~/.yarn/bin/yarn
      npm: 6.4.1 - ~/.nvm/versions/node/v8.9.1/bin/npm
      Watchman: 4.7.0 - /usr/local/bin/watchman
      Xcode: 10.1/10B61 - /usr/bin/xcodebuild
      expo: ^31.0.6 => 31.0.6
      react: 16.5.0 => 16.5.0
      react-native: => 0.57.1
      expo-cli: 2.6.8

Working by rolling back to expo-cli@2.4.3

Looks like a bug to me. Can you open an issue here?

Happening to me as well. it worked, then i updated expo-cli and then it doesnt.

Rolling back to expo-cli 2.5.0 solved the issue

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.