I keep getting the same build when i run expo build:ios

I have tried to build my app three times. Gotten three different codes:


but when I upload the build to test flight. i get the same old js code everytime

Hi, have you published your app’s JS recently? Are you able to open your published URL inside Expo Client?

No i haven’t published recently but i’ll do that now and rebuild

I published but that did not make a difference

What happens if you open your published URL in Expo Client? Does it show the newest changes you made?

yes it shows the newest changes made

For one of your Testflight builds, can you look inside the .ipa file, find EXShell.plist, and make sure it contains the same published URL?

Sorryy, how do i do that? using xcode or exp?

Just with any text editor and a file explorer. You should be able to unzip the contents of the .ipa file and you should see several files inside, including one called EXShell.plist.

Thank you, yes it does contain the same published url

Ok, that’s a good sign. Did you publish your project from a higher SDK version at some point, then downgrade back to a lower SDK version?

no, I did not. This problem just started. I had been able to upload new builds before

Hi, I’m also having this problem since yesterday.

I have tried to build my app three times, got 3 different codes, but when I try to upload using Application Loader, same js everytime…

Yes, I’ve published my app JS recently and I’m able to open my urll inside Expo Client (and it shows my newest changes).

Inside the .ipa, my EXShell.plist contains the same published URL…

Yes, I’ve published my project from a higher SDK (v24) recently, then downgrade, then upgrade again… Now it’s on SDK v24, but also not working…

Any clue?

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.