ExpoKit V32 missing assets

My expoKit project is missing all assets (fonts and images).

When I run the app on my machine whether on Android or IOS and expo is in dev I get all the assets, if i switch expo to prod then the assets dissapear.

I did expo publish, then build an APK, the APK has all its assets (and is in the store).

I build an IOS app and put it on testflight it has no assets (Disaster!).

I am using expo + expokit v32, I know v33 is out but im struggling to update it and I really need this working asap.

Thanks for any help.

HI @adamdev!

Could you share your app.json?

Also- I think this issue might be relevant to what you’re experiencing

Hi thanks for replying, im pretty sure that isnt the reason as that only relates to android apk’s which currently is the only thing working. Im much more interested in fixing IOS IPA’s.


“expo”: {
“scheme”: “name”,
“androidStatusBar”: {
“backgroundColor”: “#34353c”,
“barStyle”: “light-content”
“name”: “name”,
“description”: “our description”,
“slug”: “slug”,
“privacy”: “unlisted”,
“sdkVersion”: “32.0.0”,
“icon”: “./platformAssets/android_icon.png”,
“platforms”: [
“version”: “2.0.0”,
“orientation”: “portrait”,
“splash”: {
“image”: “./platformAssets/splash.png”,
“resizeMode”: “cover”
“updates”: {
“fallbackToCacheTimeout”: 0
“assetBundlePatterns”: [
“ios”: {
“supportsTablet”: true,
“icon”: “./platformAssets/ios_icon.png”,
“bundleIdentifier”: “com.va.name”
“android”: {
“package”: “com.va.name”,
“versionCode”: 6,
“icon”: “./platformAssets/android_icon.png”,
“googleServicesFile”: “./google-services.json”,
“publishBundlePath”: “android/app/src/main/assets/shell-app.bundle”,
“publishManifestPath”: “android/app/src/main/assets/shell-app-manifest.json”
“notification”: {
“icon”: “./platformAssets/android_icon.png”
“isDetached”: true,
“detach”: {
“iosExpoViewUrl”: “https://s3.amazonaws.com/exp-exponent-view-code/ios-v2.10.6-sdk32.0.0-e50ee83a-41bd-4965-b067-4c815a3b3fcc.tar.gz”,
“androidExpoViewUrl”: “https://s3.amazonaws.com/exp-exponent-view-code/android-v2.10.8-sdk32.0.0-bca0f957-de78-44c8-91ed-f3151372d79d.tar.gz

Your app.json file is missing both ios.publishBundlePath and ios.publishManifestPath (you can see you have both for the android key, which explains why the apk is working fine).

Thanks I have done that and im going to see if it works tomorrow after expo publish! Very, very excited if this works.

That being said i still have the same problem across both android and ios, that when I run expo in production mode (click p when expo is running) i have no assets.