Assets not showing on IOS release

Hi there,

Im having problems with my expo project. My images and the icons on @expo/vector-icons are not showing up in the release build. In debug variant all works fine but in release its not showing any image in my assets o icons. The thing its working its the images that are being loaded from url. This is working fine in android but in ios its not working on release.

Any Help?

1 Like

I am having the same issue. I’m using ExpoKit for iOS and in release none of the images (not web links) show up. But, everything looks fine on Android and development mode. I’m using Expo SDK 26.0.

Yes exactly the same!

Im reading how expo handles assets and it uploads it to an amazon server. And when you use your app it make request to that server to get that assets. Maybe the problem is at fetching that images…

I tried to fetch an image using the component and it worked on release so i dont know whats happening here

Just checking, have you published your app with exp publish recently? The assets for your app get uploaded during that step.

Yes i do it every time i make a build :slight_smile:

I publish it with the XDE app, just press publish lol

Are the assets of @expo/vector-icons are being uploaded in the publish stage too?

More info here: I updated the sdk to the 27.0.0 and works but my native library stop working :confused:

I managed to make it work! I had to remove the app from the emulator before the change of sdk. (You should add this to the documentation)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.