Expo publish not working any more

Hi guys.
I not understand why expo publish not working.
When I run project to publish after “Optimizing assets…” step nothing happens!
I run ‘expo diagnostics’ and see this:

Expo CLI 3.3.0 environment info:
OS: Windows 10
Yarn: 1.12.3 - C:\Users%USER_NAME%\AppData\Roaming\npm\yarn.CMD
npm: 6.9.0 - C:\Program Files\nodejs\npm.CMD
Android Studio: Version AI-191.8026.42.35.5900203

Can you tell me what the problem is?


Does it make a difference if you first run expo start in one terminal window and then while that is running you run expo publish in another terminal window?

Does this problem happen when publishing from the Expo Dev Tools web interface or when publishing from the command line (using the expo publish command)?

If it’s from Dev Tools, then this issue is already fixed and the fix will be released soon, in the next Expo CLI release!

Expo CLI 3.4.0 has now been released, and it has a fix to publishing from Dev Tools freezing.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.