Unable to publish

Hi everyone,

I’m having issue to publish my app.

When I do expo publish, I got this :

expo publish
Publishing to channel 'default'...

Same with expo build:ios or build:android

Even when I set EXPO_DEBUG=true

I tried to change the channel, to change the expo account.
I removed my apple credentials and profiles.

Is there a way to know what expo is doing and to get some relevant output to solve my issue ?
Any idea?

Expo CLI 3.13.1 environment info:
OS: macOS 10.15.3
Shell: 3.2.57 - /bin/bash
Node: 10.16.3 - /opt/local/bin/node
Yarn: 1.22.0 - ~/.yarn/bin/yarn
npm: 6.12.0 - /opt/local/bin/npm
Android Studio: 3.5 AI-191.8026.42.35.6010548
Xcode: 11.3.1/11C504 - /usr/bin/xcodebuild
expo: ^36.0.0 => 36.0.0
react: 16.9.0 => 16.9.0
react-native: https://github.com/expo/react-native/archive/sdk-36.0.1.tar.gz => 0.61.4
react-navigation: ^4.0.10 => 4.0.10
expo-cli: 3.13.1

Thanks for your help.



Issue solved, it was a comma at the end of a localization file declared in the app.json file.

  "NSCameraUsageDescription": "blablabla",
  "NSPhotoLibraryUsageDescription": "blablabla",

When a localization file est malformed, the expo cli does not warn you.


1 Like

Interesting. Expo does complain in at least some circumstances about invalid JSON in app.json.

I’m surprised expo diagnostics at least doesn’t complain.

expo diagnotics does not complain.
I knew the json format of the app.json was very strict.
Now I know that you won’t get any error message if the localization files are not well formatted.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.