Error "Failed to setup credentials." when running eas build

I ran
EXPO_APP_STORE_DEBUG=1 eas build --profile development --platform ios

and here is the output.

– Enabled debug logging –
:heavy_check_mark: Linked to project @haibert/Stacksharetest
:heavy_check_mark: Using remote iOS credentials (Expo server)

If you provide your Apple account credentials we will be able to generate all necessary build credentials and fully validate them.
This is optional, but without Apple account access you will need to provide all the values manually and we can only run minimal validation on them.
:heavy_check_mark: Do you want to log in to your Apple account? … yes

› Log in to your Apple Developer account to continue
:heavy_check_mark: Apple ID: …
› Restoring session /Users/hb/.app-store/auth/
200 OK (POST
› Team Simplyrem Inc. (7CUKW6T237)
200 OK (GET
› Provider Simplyrem Inc. (122073873)
:heavy_check_mark: Logged in Local session
200 OK (POST
⠋ Linking bundle identifier com.simplyrem.StacksharetestPOST
⠙ Linking bundle identifier com.simplyrem.Stacksharetest200 OK (POST
:heavy_check_mark: Bundle identifier registered com.simplyrem.Stacksharetest
⠋ Syncing capabilitiesPOST
⠙ Syncing capabilities200 OK (POST
:heavy_check_mark: Synced capabilities: No updates
Failed to setup credentials.
CombinedError: [GraphQL] Unexpected server error.
[GraphQL] Unexpected server error.

I also tried

expo build:ios --skip-credentials-check or eas build -p ios --non-interactive

still got the same error