eas build --auto-submit for iOS Error

In your post, please share:

  • Whether you are bare or managed workflow: Bare Workflow
  • Your eas-cli version: eas-cli/0.46.0 darwin-x64 node-v14.17.1
  • What you have tried so far: injected EXPO_APP_STORE_DEBUG=1, but no additional info was given

Error log:

(base) ➜  stockpeek-app git:(main_stacks) ✗ EXPO_APP_STORE_DEBUG=1 eas build --auto-submit
-- Enabled debug logging --
✔ Select platform › iOS
✔ Linked to project @stockpeek-engineering/stockpeek-test (​https://expo.dev/accounts/stockpeek-engineering/projects/stockpeek-test​)
Specifying "ios.bundleIdentifier" in app.json is deprecated for bare workflow projects.
EAS Build depends only on the value in the native code. Please remove the deprecated configuration.
✔ Using remote iOS credentials (Expo server)

If you provide your Apple account credentials we will be able to generate all necessary build credentials and fully validate them.
This is optional, but without Apple account access you will need to provide all the values manually and we can only run minimal validation on them.
✔ Do you want to log in to your Apple account? … yes

› Log in to your Apple Developer account to continue
✔ Apple ID: … stockpeek.engineering@gmail.com
› Using password for stockpeek.engineering@gmail.com from your local Keychain
  Learn more: https://docs.expo.dev/distribution/security#keychain
⠋ Logging in...POST https://idmsa.apple.com/appleauth/auth/signin
⠏ Logging in...Error: Request failed with status code 403 (POST https://idmsa.apple.com/appleauth/auth/signin)
✖ Logging in...
Authentication with Apple Developer Portal failed!
    Error: Apple Service Error -1018. Could Not Complete Request. Your request could not be completed because of an error. Please try again later. 
    Apple servers may be down right now, please try again in about 10-20 minutes
  1. I have a working Apple Developer account. Apple ID: stockpeek.engineering@gmail.com
  2. Ensured that the password is correct
  3. Tried to Google “Apple Service Error -1018”, couldn’t find any pointers

Any help is well appreciated ! :grinning:

try signing in to your apple developer account and accepting any outstanding agreements.


you may see something like this:

follow those instructions

Same problem after eas build on ios, dont have any agreements to accept :confused:

can you try running EXPO_NO_KEYCHAIN=1 EXPO_APP_STORE_DEBUG=1 npx @expo/apple-utils login and share the output please?