Development Loading Old Code

I’ve inherited a code base from another developer who I don’t have contact with. It uses expo, I’ve got the service running, and it will load the app. But no matter what changes I make, it loads the unedited version that loaded originally, even if I comment out the entire App.js. I’ve turned off auto-backup on my Android device, and run with “expo start --clear --dev --no-minify”.

Any advice? I’m terribly confused.

Expo CLI 3.11.7 environment info:
OS: Windows 10
npm: 6.4.1 - C:\Program Files\nodejs\npm.CMD
Android Studio: Version


I once had a weird issue where when trying to load one app in Expo on Android it actually loaded (mostly) a completely different app that I had been working on previously. I tried clearing all sorts of caches etc. on my laptop, but nothing helped. In the end I had to clear the cache or data (I think I cleared both, but maybe the cache would have been sufficient) on the app on the phone and that fixed it.

Not sure if you’re seeing the same issue, but if all else fails, clear the Expo app’s cache and data on the Android device.

Oddly enough, I have also tried clearing both app data and cache data many times, and even doing a complete re-install after clearing both, including permissions resetting.

I’m having similar issues with iOS and clearing caches/data is not helping.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.