Expo App Stuck On An Older Version

So i just made an app for fun and started it on web it worked fine then i changed some code and saved it but the app didnt change i tried stopping expo and doing expo start again but it was stuck on that version i tried changing the code again but it still didnt work i tried it on android too and that was the same for android too
i even deleted the project folder and created a new project i reinstalled expo-cli and still its the same

please help

Hey @fuzfy,

Are you saying when you reload the project it remains the same? If you’re expecting the change to happen upon save, can you make sure that you have the Fast Refresh setting enabled in the Developer Menu?

If even upon restarting the project the changes haven’t taken effect, can you try running expo start -c to clear your javascript transform cache and see if that helps?


i tried doing expo start -c and then opening it on web but it’s still the same.

edit: i tried publishing it and running it on an appetize android simulator and it opened the correct version but when i tried to open it on web again it opened the old version again

Is this only occurring when running the web version of your app?

Yes i tried on it an android physical device and it worked fine with fast reload and everything but the web version still shows the old version

It’s the opposite for me. The web reloads the latest build but on my android physical device it refuses to do that no matter what i do

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.